Seltsamer Effekt bei Album-Navigation

Diskussion zum Modul Gallery / Bilderalbum für ConPresso 4
Benutzeravatar
Marky
ConPresso-Checker
Beiträge: 382
Registriert: 11.12.2005 16:29
Hat sich bedankt: 29 Mal
Danksagung erhalten: 18 Mal

Seltsamer Effekt bei Album-Navigation

Beitrag von Marky »

Hallo,

wenn ich über die Album-Navigation auf eine weitere Album-Seite wechsele stellt sich bei mir ein seltsamer Effekt ein:
Also: Ich gebe eine Galerie-Zeilenanzahl von 1 vor, so dass sich eine Album-Navigation in der Seite einstellt. Klicke ich in der Navi auf die 2. Albumseite, dann sieht es so aus, als würde der erste Teil des Artikels bis zur SLIDESHOW:Table nicht in die 2. Seite eingebaut werden, denn dieser Bereicht fehlt in Browser-Sicht.
Dem ist aber nicht so. Im Quelltext steht alles korrekt. Wenn ich mir den Quelltext der Seite lokal hinkopiere und als HTML-Datei öffne, dann wird die Seite korrekt dargestellt. Nur wenn ich über die Navigations-Links des Albums gehe, ist dieser Teil immer weg.
Kann das mit der (zeitlichen) Reihenfolge des Renderns zusammen hängen? Kenn' mich da ja überhaupt nicht aus, ob sich so ein Effekt im Zusammenhang mit CSS dadurch einstellen kann, aber ich sehe keine Fehler in der Seite, denn die Detailseite (vom Teaser aus verlinkt) ist immer korrekt. :gruebel:
Von daher war meine Vermutung, dass das damit was zu tun haben könnte.

Echt "strange" ?!
Gruß
Marky
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7115
Registriert: 01.01.1970 02:00
Hat sich bedankt: 102 Mal
Danksagung erhalten: 916 Mal

Beitrag von MarkusR »

Das liegt wohl am Rendern durch den Browser.

Wenn man die Seite neu lädt, dann wird sie wieder korrekt angezeigt. Offensichtlich scrollt der Browser korrekt zur angegebenen Sprungmarke (z.B. #Dianaquelle) vergisst dabei aber die Rollbalken in die Seite einzubauen oder eben das DIV korrekt anzupassen.

Nachtrag: das Abschneiden wird sicher durch die CSS-Eigenschaft overflow: hidden; begünstigt. Ich schreibe bei sowas ein auto hinein...
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Benutzeravatar
Marky
ConPresso-Checker
Beiträge: 382
Registriert: 11.12.2005 16:29
Hat sich bedankt: 29 Mal
Danksagung erhalten: 18 Mal

Beitrag von Marky »

hm ... würde mal sagen: Sche....
Das overflow:hidden gehört zu dem Mega-Hack, der dazu gebraucht wird, dass die Navigationsleiste (d.h. farbige Hintergrund) mit dem Content-Bereich mitwächst, wenn die Spalten anstatt mit Tabellen nur mit DIVs gestyled werden. Ist nicht so einfach mit CSS zu machen.
Bei overflow:auto, ist die Seite komplett "destroyed". :(

Wird denn die Seite über die Navi nicht mehr komplett gerendert, sondern nur der Slideshow-Bereich ausgetauscht, oder wie könnte man sich dieses Zustandekommen dieser Unterschiede erklären, im Gegensatz, wenn ich das erste Mal auf die Detailseite gehe (d.h. über den Teaser), oder wie muss ich mir das vorstellen ?
Gruß
Marky
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7115
Registriert: 01.01.1970 02:00
Hat sich bedankt: 102 Mal
Danksagung erhalten: 916 Mal

Beitrag von MarkusR »

Ich würde in der Bildübersicht-Vorlage einfach <a name="### ALBUM_ANCHOR ###"> rausnehmen, was dafür gebraucht wird bei mehreren Galereien auf einer Seite zur richtigen zu springen.
Da Du nur eine je Seite hast ist das also überflüssig.
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Benutzeravatar
Marky
ConPresso-Checker
Beiträge: 382
Registriert: 11.12.2005 16:29
Hat sich bedankt: 29 Mal
Danksagung erhalten: 18 Mal

Beitrag von Marky »

Super. Vielen Dank.
Das hat geholfen. :!:
Gruß
Marky