Testversion 4.2

Diskussion zum Modul Newsletter für ConPresso 4
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7186
Registriert: 01.01.1970 02:00
Hat sich bedankt: 104 Mal
Danksagung erhalten: 919 Mal

Testversion 4.2

Beitrag von MarkusR »

Hier etwas für die Experimentierfreudigen!

Der Newsletter steht als Testversion 4.2 zum Download bereit
http://conpresso4.de/_reg_downloads/ind ... =Downloads

Diese Version ist ausdrücklich zum Testen bestimmt und sollte nicht ohne administrative Vorsichtsmaßnahmen getestet werden (Backup, Testinstallation, etc.)

Was ist neu?
  • das Modul kann mehrfach installiert werden
    (dabei erhält das Modul, die Rubrik und das Template den Verzeichnisnamen, der daher sinnvoll gewählt werden sollte!)
  • Personalisierung durch beliebige Felder
  • Das Ranking-System bietet weitere Optionen
  • Die Kategorien werden jeweils in ein eigenes DIV eingeschlossen
Dies ist kein Update der bisherigen Version!
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7186
Registriert: 01.01.1970 02:00
Hat sich bedankt: 104 Mal
Danksagung erhalten: 919 Mal

Beitrag von MarkusR »

Manches finde ich auch ohne Tester... :twisted:

Aufgrund der vollständigen Codeüberarbeitung blieb leider die eigentliche Ausgabe der Newsletter etwas auf der Strecke, was ich jetzt wieder behoben habe.

Zusätzlich habe ich jetzt noch etwas eingebaut, was ich selbst für überflüssig halte, was aber mehrfach angefragt wurde:
  • Aus den Index-Teilen der freigegebenen Artikeln lässt sich ein Newsletter zusammenklicken
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

Hi Markus,

da ja anscheinend doch nicht so viele den Newsletter testen und feedback geben, mach ichs mal ;-)

Also mal allgemein gesagt finde ich es cool, dass man im neuen Newslettermodul einzelne Artikel zuweisen kann, ist ech eine bereicherung!!

Jedoch habe ich schon mal den ersten Fehler!

Nachdem ich den Newsletter installiert habe und dann wieder ins Module verwalten gehen wollte kam folgender fehler

Fatal error: Cannot redeclare newsletter_install() (previously declared in /www/htdocs/v270096/mod_test_newsletter/common-module.inc.php:428) in /www/htdocs/v270096/mod_newsletter/common-module.inc.php on line 396

Anscheinend kommt das System in Konflikt, wenn man noch die 4.1 Version und als 2. die 4.2 Version installiert hat.

lg, like_it
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

Und gleich der nächste Fehler ;-)

Warning: Invalid argument supplied for foreach() in /www/htdocs/v270096/mod_test_newsletter/includes/inc_out.inc.php on line 51

Database error:
Invalid SQL: SELECT count(id) AS send_count FROM fratz__mod_newsletter_adresses WHERE active = 1 AND newsletter='mod_test_newsletter' AND ( )
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 1 (1064)

Wenn man auf versenden klicken möchte
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

Ich habe mal beide Fehlermeldungen behoben, indem ich 1. die 4.1 Version vom Server gelöscht habe und 2. das neue Newslettermodul mal deinstalliert und wieder neu installiert habe.

Wenn ich nun einen Newsletter zusammenstellen möchte, zeigt er mir die gewählten Artikel in der Vorschau zwar an, gebe noch einen Titel, wenn ich jedoch auf "gewählte Artikel als Newsletter speichern" klicke, dann kommt eine leere Seite und der Newsletter wird nicht in der Rubrik gespeichert.

Weiters habe ich ein Riesenproblem, egal in welcher Version ob 4.1 oder 4.2, mein Newsletter wird nicht versendet. Er bestätigt mir den Versand der Newsletter jedoch kommen diese nie an.

Vom Server her kann nichts sein, ich habe ein 2. Projekt mit einem Newslettermodul 4.1 installiert und dort funktioniert der Versand einwandfrei.

lg,

like_it
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7186
Registriert: 01.01.1970 02:00
Hat sich bedankt: 104 Mal
Danksagung erhalten: 919 Mal

Beitrag von MarkusR »

like_it hat geschrieben:Ich habe mal beide Fehlermeldungen behoben, indem ich 1. die 4.1 Version vom Server gelöscht habe und 2. das neue Newslettermodul mal deinstalliert und wieder neu installiert habe.
Anders geht es ja nicht, da die 4.1 keine weitere Newsletter-Installation erlaubt, was ja eben die Neuerung bei der 4.2 ist
MarkusR hat geschrieben:das Modul kann mehrfach installiert werden
like_it hat geschrieben:Wenn ich nun einen Newsletter zusammenstellen möchte, zeigt er mir die gewählten Artikel in der Vorschau zwar an, gebe noch einen Titel, wenn ich jedoch auf "gewählte Artikel als Newsletter speichern" klicke, dann kommt eine leere Seite und der Newsletter wird nicht in der Rubrik gespeichert.

Weiters habe ich ein Riesenproblem, egal in welcher Version ob 4.1 oder 4.2, mein Newsletter wird nicht versendet. Er bestätigt mir den Versand der Newsletter jedoch kommen diese nie an.

Vom Server her kann nichts sein, ich habe ein 2. Projekt mit einem Newslettermodul 4.1 installiert und dort funktioniert der Versand einwandfrei.
Tja, das mit dem Nichtspeichern des zusammengeklickten Newsletters ist merkwürdig.

Daß der Versand nicht funktioniert ist da noch ungewöhnlicher.
Bist Du denn sicher, daß das von Dir benutzte Account Mails versenden kann? Da im Modul ein Check mit einem einfachen mail() eingebaut ist, aber auch dieses Mail nicht versendet wurde, scheint das Account einfach keinen Mailversand unter den herrschenden Bedingungen zu unterstützen.

Leider weiß ich zu wenig über Deinen Server und die Beschreibungen von dem, was Du sonst auf dem Bildschirm siehst, sind auch nicht so arg ausführlich. Wird z.B. überhaupt in die zugehörige Rubrik gewechselt? Wird ggf. was in der DB gespeichert aber ohne Angabe der Rubrik?
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

Hallo Markus,

das mit dem Mail versenden hat sich erledigt. Jedoch, das mit dem zusammenstellen des Newsletters nicht.

Weiterhin habe ich keine artikeln mehr drinnen, sobald ich auf fertig klicke.

Noch eine Anregung vielleicht: Wenn man jetzt z.b. 10000 adressen drinnen hat und einen Newsletter versenden möchte, habe ich zwar das vorschaufenster, wie der newsletter aussehen könnte, jedoch kann ich mir nicht sicher sein, dass es auch so ist. gibt es vielleicht eine möglichkeit, diesen newsletter nochmals an die adminmail zu senden, bevor ich dann endgültig an die z.b. 10000 user raussende?

lg,
like_it
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7186
Registriert: 01.01.1970 02:00
Hat sich bedankt: 104 Mal
Danksagung erhalten: 919 Mal

Beitrag von MarkusR »

like_it hat geschrieben:das mit dem Mail versenden hat sich erledigt. Jedoch, das mit dem zusammenstellen des Newsletters nicht.
MarkusR hat geschrieben:Leider weiß ich zu wenig über Deinen Server und die Beschreibungen von dem, was Du sonst auf dem Bildschirm siehst, sind auch nicht so arg ausführlich. Wird z.B. überhaupt in die zugehörige Rubrik gewechselt? Wird ggf. was in der DB gespeichert aber ohne Angabe der Rubrik?
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Benutzeravatar
hscha
ConPresso-Experte
Beiträge: 573
Registriert: 22.02.2006 23:00
Wohnort: Berlin
Hat sich bedankt: 202 Mal
Danksagung erhalten: 19 Mal

Beitrag von hscha »

Hallo Markus,

ich habe gestern die 4.2 installiert. Mir geht's genauso wie like_it:
like_it hat geschrieben:
... Jedoch, das mit dem zusammenstellen des Newsletters nicht...
Den Rest probiere ich jetzt aus...

Grüße von
H.Schallnas
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7186
Registriert: 01.01.1970 02:00
Hat sich bedankt: 104 Mal
Danksagung erhalten: 919 Mal

Beitrag von MarkusR »

hscha hat geschrieben:Hallo Markus,

ich habe gestern die 4.2 installiert. Mir geht's genauso wie like_it:
like_it hat geschrieben:
... Jedoch, das mit dem zusammenstellen des Newsletters nicht...
Den Rest probiere ich jetzt aus...

Grüße von
H.Schallnas
Leider weiß ich zu wenig über Deinen Server und die Beschreibungen von dem, was Du sonst auf dem Bildschirm siehst, sind auch nicht so arg ausführlich. Wird z.B. überhaupt in die zugehörige Rubrik gewechselt? Wird ggf. was in der DB gespeichert aber ohne Angabe der Rubrik?
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Benutzeravatar
hscha
ConPresso-Experte
Beiträge: 573
Registriert: 22.02.2006 23:00
Wohnort: Berlin
Hat sich bedankt: 202 Mal
Danksagung erhalten: 19 Mal

erledigt

Beitrag von hscha »

Hallo Markus,

das Problem hat sich mit den Rückbenennung der Rubrik in "mod_newsletter" erledigt. Jetzt wird ein neuer Artikel angelegt und auch angezeigt.

Grüße von
H.Schallnas
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

Hi Markus,

das mit dem Newsletter zusammenstellen hat sich auch aus irgendeinem Grund erledigt ;-)

Wir haben gestern mal einen Testnewsletter an 1800 Personen geschickt! Problemlos ;-)

Jetzt wäre noch eine Frage meinerseits.

Wenn man sich registriert, dann erhält man einen Link zum Austragen wieder, der den Platzhalter [<!-- NL-UNSCRIBE-LINK -->] hat.

Wenn ich den jetzt jedoch auch im Unsubscribe Textfeld eingebe, dann kommt nur []. Dort wird ja nur auf die mod_newsletter Seite hingewiesen.

Wäre es nicht auch besser, dort die möglichkeit des Platzhalter [<!-- NL-UNSCRIBE-LINK -->] einzufügen bzw. wie kann man es realisieren, dass dieser Link mit der Hash Nummer versendet wird.

Weiters noch meiner Meinung nach ein sehr sehr wichtiger Punkt wäre das überprüfe von doppeleinträgen. beim neuen Empfänger anlegen, bzw. bei einer CSV datei hochladen. Denn ich habe 2 Newsletter, einmal Business udn dann Kunden. Und bei den Kunden sind ca. 10.000 Empfänger gelistet, da wird das dann schon sehr unübersichtlich, wenn ich nach ein promotion ca. 100 Empfänger eintrage und zuerst aber nachsehen muss, ob es ihn schon gibt ;-)

lg, like_it
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7186
Registriert: 01.01.1970 02:00
Hat sich bedankt: 104 Mal
Danksagung erhalten: 919 Mal

Beitrag von MarkusR »

Das mit dem unscribe-Link werde ich mir am WE mal ansehen.

Was die Gefahr doppelter Adressen angeht existiert diese eigentlich gar nicht.
Bei dem normalen Eintragen wird geprüft, ob es die Adresse schon gibt und auch beim Import von Listen werden doppelte Einträge höchstens aktualisiert (z.B. neuer Name), aber nicht doppelt eingetragen.
Einfach mal ausprobieren oder ich habe was falsch verstanden...
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

Hallo Markus,

danke für die Hilfe, bin schon gespannt auf dein ergebnis mit dem Unsubscribe Link ;-)

Bzgl. Doppeleinträge, wenn ich einen neuen Eintrag (Empfänger eintragen) im CMS System mache, dann überprüft er dieses nicht, und ich kann 2 mal die gleiche email Adresse eintragen.

Bei hochladen der Liste glaube ich auch, dass es nicht funktionert, bzw. das System überprüft, bin mir aber nicht sicher, was mir nur aufgefallen ist, wenn ich eine Liste versuche 2 mal hochzuladen, dann stehen die Adressen nicht doppelt drinnen.

lg, Michael
like_it
ConPresso-User
Beiträge: 42
Registriert: 21.04.2006 15:46
Wohnort: Wien

Beitrag von like_it »

hallo markus,

bist du zu einem ergebnis bzgl. den platzhaltern gekommen?

lg, michael