parse error bei installation 4.1.5

Fragen zur Installation von ConPresso 4 werden in diesem Forum diskutiert.
Ulrich Krause
ConPresso-User
Beiträge: 41
Registriert: 27.02.2007 10:41
Wohnort: 63075 Offenbach
Hat sich bedankt: 4 Mal

parse error bei installation 4.1.5

Beitrag von Ulrich Krause »

"Parse error: syntax error,
unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}'
in /homepages/7/d216873517/htdocs/_include/anti_csrf.inc.php on line 19"

diese Meldung erhalte ich bei der Neuinstallation von 4.1.5. als Meldung auf der Seite 3/3 Schritte.

Gibt es eine Lösung?

Uli
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7115
Registriert: 01.01.1970 02:00
Hat sich bedankt: 102 Mal
Danksagung erhalten: 916 Mal

Beitrag von MarkusR »

Gibt es eine Lösung?
PHP-Version < 5 ???

siehe http://community.conpresso.de/viewtopic ... 7279#27279
Minimum sollte im Moment ein PHP5 sein. PHP 4 sollte man aus Sicherheitsgründen schon nicht mehr einsetzen. Im 4.1er Zweig von CPO werden objektorientierte Funktionen von PHP 5 eingesetzt, so dass das auch die minimale Version hierfür sein sollte.
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Ulrich Krause
ConPresso-User
Beiträge: 41
Registriert: 27.02.2007 10:41
Wohnort: 63075 Offenbach
Hat sich bedankt: 4 Mal

4.1.5 mit php 5.2 das läuft

Beitrag von Ulrich Krause »

Hallo, Markus,
ich bin bei 1und1 und dort kann man die PHP-Version 4, 5.2 oder 5.4 einsellen.
Bei 5.2 gibt es den Fehler nicht mehr.
Danke für die schnelle Reaktion.
Uli :D
toemmel
ConPresso-Newbie
Beiträge: 1
Registriert: 28.01.2013 14:27

Beitrag von toemmel »

Bekomme bei der Installation von Conpresso ebenfalls die Fehlermeldung, auf unserem Webserver läuft PHP4.

Gibt es hier einen "Workaround" um Conpresso 4.1.5. auch mit PHP4 zum Fliegen zu bekommen? Hintergrund: Derzeit läuft unsere Webseite noch unter Conpresso 3.x und ich möchte Conpresso 4.1.5 parallel installieren und nach ausgiebigen Tests umschalten.

Daher ist die Umschaltung auf PHP5 (derzeit noch) nicht möglich.

Schöne Grüße
Toemmel
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7115
Registriert: 01.01.1970 02:00
Hat sich bedankt: 102 Mal
Danksagung erhalten: 916 Mal

Beitrag von MarkusR »

Benutze 4.0.12. Der 4.1.x-Zeig läuft NICHT mit PHP4.

Ich nutze 3.4.8 mit PHP 5.2.6, warum sollte eine Nutzung von PHP <5.4 nicht möglich sein?
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
Benutzeravatar
balu
ConPresso-Entwickler
Beiträge: 1748
Registriert: 01.01.1970 02:00
Hat sich bedankt: 81 Mal
Danksagung erhalten: 133 Mal

Beitrag von balu »

Das Update der Datenbank von 4.0 auf 4.1 ist dann sehr einfach mit einem Script durchgeführt.

Wenn also nicht PHP5 < 5.4 geht, könnte man erst 4.0 nehmen und dann auf 4.1 updaten.

Balu
Bartels.Schöne
ConPresso Support & Development