Komme nicht zum installiren auf /_setup

Fragen zur Installation von ConPresso 4 werden in diesem Forum diskutiert.
sKa
ConPresso-Newbie
Beiträge: 7
Registriert: 20.10.2011 18:02

Komme nicht zum installiren auf /_setup

Beitrag von sKa »

Hallo zusammen,
komme nach dem ftp-Upload nicht zur instalation weiter auf /_setup.
Der Browser zeigt nur

Warning: Wrong datatype for first argument in call to array_key_exists in /mnt/web5/30/18/539318/htdocs/conpresso-4.1.2/_include/translation.inc.php on line 68

Ich habe schon öfter installiert, bis jetzt immer unproblematisch.

Die Daten sind bei Strato.de abgelegt.

Schon mal vielen Dank für eure Hilfe!
Benutzeravatar
balu
ConPresso-Entwickler
Beiträge: 1748
Registriert: 01.01.1970 02:00
Hat sich bedankt: 81 Mal
Danksagung erhalten: 133 Mal

Beitrag von balu »

Hallo sKa,

kannst Du in der angegebenen Datei bitte einmal die folgende Zeile einfügen?

var_dump($l);

Die Zeile muss vor die Zeile 68, die so aussieht:

if (array_key_exists($l, $this->languageCache)) {

Ausserdem wüsste ich gerne, welche PHP-Version Du da einsetzt. Die Info erhältst Du (nach Freischaltung in der Datei durch entfernen von //) durch Aufruf der Seite phpinfo.php

Balu
Bartels.Schöne
ConPresso Support & Development
sKa
ConPresso-Newbie
Beiträge: 7
Registriert: 20.10.2011 18:02

Komme leider immer noch nicht zum installiren auf /_setup

Beitrag von sKa »

Hallo Balu,
erst einmal vielen Dank für Deine schnelle Hilfe!!!

Ich habe vor der Zeile 68 in der ranslation.inc.php Deinen PHP-Schnipsel var_dump($l); eingesetzt.

Leider kein Erfolg. Das Resultat im Browser:
string(7) "english" NULL
Warning: Wrong datatype for first argument in call to array_key_exists in /mnt/web5/30/18/539318/htdocs/conpresso-4.1.2/_include/translation.inc.php on line 68

Die PHP Version bei Strato ist 4.1.2

Bitte noch mal helfen.

Viele Grüße sKa
Benutzeravatar
balu
ConPresso-Entwickler
Beiträge: 1748
Registriert: 01.01.1970 02:00
Hat sich bedankt: 81 Mal
Danksagung erhalten: 133 Mal

Beitrag von balu »

Hi,

gibt es einen Grund, wieso da ein derart altes PHP läuft? Die Version 4.1.2 ist fast 10 Jahre alt!

Ich weiss nicht, ob da eventuell eine Software läuft, die diese alte PHP-Version braucht. Ansonsten sollte vielleicht im Strato Konfigurationscenter die PHP-Version auf eine aktuelle 5er Version gesetzt werden:

http://www.strato-faq.de/artikel.html?id=1568

Balu
Bartels.Schöne
ConPresso Support & Development
sKa
ConPresso-Newbie
Beiträge: 7
Registriert: 20.10.2011 18:02

Beitrag von sKa »

Hallo Balu,
habe den conpresso-Ordner bei Strato auf 5.2.17 umgestellt.

Jetzt wird unter _setup das hier angezeigt

string(7) "english" NULL

Gruß sKa
Benutzeravatar
balu
ConPresso-Entwickler
Beiträge: 1748
Registriert: 01.01.1970 02:00
Hat sich bedankt: 81 Mal
Danksagung erhalten: 133 Mal

Beitrag von balu »

Hi,

Du musst jetzt das var_dump() wieder rausnehmen. Das war nur zu Debuggingzwecken, damit ich diese beiden Werte sehen kann. :-)

Balu
Bartels.Schöne
ConPresso Support & Development
sKa
ConPresso-Newbie
Beiträge: 7
Registriert: 20.10.2011 18:02

Beitrag von sKa »

Hallo Balu,
habe das var_dump() wieder rausgenommen.

Komme bis zum Schritt 1/3 und bekomme die Meldung:

Problem: Es sieht aus, als wären nicht alle Dateien oder Verzeichnisse korrekt übertragen worden:
_include/translation.inc.php, NEU-in-4-1_deutsch.txt
Lösung: Bitte stellen Sie sicher, dass alle Dateien und Verzeichnisse, die im Archiv enthalten waren, korrekt auf den Server übertragen wurden. Achten Sie dabei darauf, dass auch die Verzeichnisstruktur identisch bleibt.

was ich nicht bestätigen kann die Daten sind alle korrekt abgelegt.


Gruß sKa
Benutzeravatar
MarkusR
Handbuchversteher
Beiträge: 7115
Registriert: 01.01.1970 02:00
Hat sich bedankt: 102 Mal
Danksagung erhalten: 916 Mal

Beitrag von MarkusR »

Du hast Dateien geändert und die eine ist eh (ab Werk) fehlerhaft.

Daher jetzt in _include/md5_files.inc.php
nach der Zeile

Code: Alles auswählen

$md5_files = array(
noch ein

Code: Alles auswählen

'off'=>'off',
eintragen, womit die Datei am Anfang so aussieht

Code: Alles auswählen

<?php
$md5_files = array(
    'off'=>'off',
    '_manual' => '',
    '_manual/index.php' => 'e4c9fbfc4b5268681e6d2a70a7e516a8',
    '_manual/toc.php' => '00fe1962210a6ad96b36a19e6ff521d9',
    '_manual/missing.php' => '1044dac09ac0734a87417bc87fa4adbe',
    '_manual/deutsch' => '',
Ciao Markus
ConPresso-Module

Kein Support per PN!!! Für Fragen und Diskussionen ist das Forum da!

Succi recentis officinalis
Hochwertige Kräutersäfte und -Öle
sKa
ConPresso-Newbie
Beiträge: 7
Registriert: 20.10.2011 18:02

Beitrag von sKa »

':D' Hallo zusammen,
jetzt funktioniert alles.


Vielen Dank an alle
sKa
':D'